找回密码
 立即注册
搜索
热搜: ROOT 面具 串号

易语言随机生成字母或者随机数字、汉字怎么实现呢?

欢呼踢仙人掌 | 2023-11-16 19:40:09 | 显示全部楼层 |阅读模式
前言:
有时候在使用易语言过程中我们经常遇到一些需要随机生成的问题,今天我们就讲一下如何用易语言生成随机数字、随机字母、随机汉字的功能效果,非常简单,只需要调用精易模块就可以,具体怎么做呢,请看我下面的图文操作,一步步来就行了
精易模块v8下载地址:
https://jy125.lanzouw.com/iyJ6m141n0uf
教程开始:
1、我们还是先打开易语言,然后新建一个窗口,弄三个编辑框,三个按钮,如下图
截图202311161931394222.png

2、然后我们需要把精易模块导入进来,模块下载地址在上面,双击模块引用表

截图202311161934566320.png

3、选择精易模块,然后点打开就行了
截图202311161935277706.png

4、然后进入启动窗口,双击随机数字按钮,粘贴如下代码
  1. .版本 2

  2. .子程序 _按钮1_被单击

  3. 编辑框1.内容 = 文本_取随机数字 (10)

复制代码
5、然后双击随机字母按钮粘贴如下代码
  1. .版本 2

  2. .子程序 _按钮2_被单击

  3. 编辑框2.内容 = 文本_取随机字母 (10)
复制代码
6、然后双击随机汉字按钮,粘贴如下代码
  1. .版本 2

  2. .子程序 _按钮3_被单击

  3. 编辑框3.内容 = 文本_取随机汉字 (10)
复制代码
7、然后运行程序,点击每个按钮看下对应的随机生成效果,可以生成了,这个生成的数量也可以控制的,比如“文本_取随机汉字 (10)”你改成“文本_取随机汉字 (30)”它就会生成30个随机汉字
截图202311161939134732.png


漂亮扯热狗 | 2023-11-16 19:40:45 | 显示全部楼层
  1. .版本 2

  2. .程序集 窗口程序集_启动窗口

  3. .子程序 _按钮1_被单击

  4. 编辑框1.内容 = 文本_取随机数字 (10)


  5. .子程序 _按钮2_被单击

  6. 编辑框2.内容 = 文本_取随机字母 (10)

  7. .子程序 _按钮3_被单击

  8. 编辑框3.内容 = 文本_取随机汉字 (10)

复制代码
完整代码
忐忑向 | 2023-11-16 19:40:53 | 显示全部楼层

感谢分享
愉快爱冬天 | 2023-11-16 19:41:21 | 显示全部楼层
谢谢分享哈!!!太详细了
柔弱等于小猫咪 | 2023-11-16 19:41:56 | 显示全部楼层
精英模块的功能就是强悍
痴情方星星 | 2023-11-16 19:42:21 | 显示全部楼层
这个就是调用了其他模块
健忘黄豆 | 2023-11-16 19:43:22 | 显示全部楼层
痴情方星星 发表于 2023-11-16 19:42
这个就是调用了其他模块

易语言不调用模块你实现这种效果估计要写大半天
斯文用人生 | 2023-11-16 19:45:04 | 显示全部楼层
楼上说的对
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

新壳软件 |网站地图

GMT+8, 2023-12-11 16:21 , Processed in 0.063745 second(s), 29 queries .

Powered by Discuz! X3.5

© 2001-2017 Comsenz Inc.